Toshiba Tecra 8000 RAM upgrade reveals problem

Today I received the two 128MB memory modules I ordered. I selected the Transcend TS128MT7000 SODIMM, because it is the cheapest option available to me that is 100% compatible with my version of the Tecra 8000 (Pentium II 400Mhz).

But I noticed a couple of interesting things when I removed the old modules and installed the new ones.

First: the original 64MB Toshiba SODIMM installed in slot B was quite firmly inserted, and required a bit of cradling to remove. But the other no-name brand 64MB module in slot A just slided out of the socket almost by itself.

Second: the computer did not boot after installing the new modules. I got exactly the same problem I had a couple of days ago. No BIOS! This was probably not a coincidence. So, time for some experiments.

First I removed both new modules, and inserted the original Toshiba 64MB module back in slot B. Then I booted: it worked again! I could not help but observe how incredibly slow the system was, with only 64MB of ram. I shut the system down again.

Next I added a 128MB module to slot A and rebooted. But this time, no BIOS! Then I replaced the 128MB module for the other one, to rule out a broken module being the cause. But again, no BIOS! Finally I inserted the no-name 64MB module back in slot A, the situation as it was before I began the upgrade, but this time the computer also refused to boot! Perhaps there is something fishy going on with slot A? Time to continue the experiment.

I then removed all the modules, and inserted one of the new 128MB modules in slot B. I booted the system, and it worked! Then I added the Toshiba module to slot A. Again I noticed that this module requires a bit of cradling to insert. I rebooted: success!

I now had 192MB of RAM, I was finally making progres. Next I removed the 64MB Toshiba module from slot A and replaced it with the no-name brand 64MB module which slid right in as if it was barely making contact. This time the computer booted, *BUT* it only registered 128MB RAM! Apparently, the system was not even registering that the module had been inserted. And now it is perfectly clear to me that the no-bios problems I have experienced recently are related to the slot A memory bank.

So now I’ve reinstalled the 64MB Toshiba module, and am back to 192MB RAM. I am not sure what I can do to fix this problem, besides trying to find an original Toshiba 128MB pc66 SODIMM. I’ll have to think about this, but at least it seems that I’ve solved the mystery of the boot failure s I experienced.

[NEW UPDATE]
Due to the fact that I have become less dependent upon this laptop, I have now been brave enough to try a solution that I have been thinking about for some time. My new theory is that the new modules are slightly thinner than the original, and that this causes the contacts of the modules to be insufficiently pressed against the connectors. This problem occurs in both slots, but appears to be more severe with slot A.

So now I have simply cut four rectangular strips out of the thin hard cardboard from the back of my notepad, in the shape of the modules. After inserting the modules, I stacked two strips of this cardboard on each of the modules and then pressed the cover back in place. It took quite a bit of pressure to keep that covering plate down while I tightened the screws, so I knew those modules where being forced against the connectors. After I finished, I crossed my fingers and booted up.

And it works! I finally have the maximum 256MB RAM at my disposal! This laptop is now as fast as it is ever going to get, and I must say that it certainly seems to be faster than it’s ever been.

My only concern has to do with overheating. The memory modules get mighty hot during use, so I’ll have to check the cardboard strips in a while, just to make sure it’s not going to catch fire ;-)

Advertisements

One Response to Toshiba Tecra 8000 RAM upgrade reveals problem

  1. […] [UPDATE] Read more about how the memory upgrade is going over HERE […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: